"Grub Customizer" does not work

Hello everybody

I would like to boot permanently with the 5.11.4-arch1-1 instead of selecting it in the GRUB window.
I assume that I can set this up in the “Grub Customizer”. However, it does not open after registration.
Am I doing something wrong?

:: inxi -Fxxxza
System:
  Kernel: 5.11.4-arch1-1 x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-linux 
  root=UUID=dd35d277-4d30-47cc-836e-6a9acd096ed2 rw quiet loglevel=3 audit=0 
  Desktop: KDE Plasma 5.21.2 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 dm: SDDM 
  Distro: HefftorLinux v2021-02-05 
Machine:
  Type: Laptop System: Acer product: Aspire A517-51G v: V2.03 serial: <filter> 
  Mobo: KBL model: Dragonite_KL v: V2.03 serial: <filter> UEFI: Insyde v: 2.03 
  date: 05/22/2019 
Battery:
  ID-1: BAT1 charge: 45.9 Wh condition: 45.9/48.9 Wh (94%) volts: 16.7/15.2 
  model: LG 004B384234314341 type: Li-ion serial: <filter> status: Full 
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse serial: <filter> 
  charge: 55% (should be ignored) rechargeable: yes status: Discharging 
CPU:
  Info: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP arch: Kaby Lake 
  note: check family: 6 model-id: 8E (142) stepping: A (10) microcode: B4 
  L2 cache: 8 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 32012 
  Speed: 800 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 
  5: 800 6: 799 7: 800 8: 800 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, 
  STIBP: conditional, RSB filling 
  Type: srbds status: Vulnerable: No microcode 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel UHD Graphics 620 vendor: Acer Incorporated ALI driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:5917 class ID: 0300 
  Device-2: NVIDIA GP108M [GeForce MX150] vendor: Acer Incorporated ALI driver: N/A 
  alternate: nouveau bus ID: 01:00.0 chip ID: 10de:1d10 class ID: 0302 
  Device-3: Quanta HD Webcam type: USB driver: uvcvideo bus ID: 1-7:4 
  chip ID: 0408:a060 class ID: 0e02 serial: <filter> 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: loaded: modesetting 
  unloaded: fbdev,vesa alternate: intel display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 128 size: 381x214mm (15.0x8.4") 
  diag: 437mm (17.2") 
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.3.4 
  direct render: Yes 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus ID: 00:1f.3 
  chip ID: 8086:9d71 class ID: 0403 
  Sound Server: ALSA v: k5.11.4-arch1-1 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 3000 bus ID: 02:00.1 
  chip ID: 10ec:8168 class ID: 0200 
  IF: enp2s0f1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Lite-On 
  driver: ath10k_pci v: kernel modules: wl port: 3000 bus ID: 03:00.0 
  chip ID: 168c:0042 class ID: 0280 
  IF: wlp3s0 state: down mac: <filter> 
  Device-3: Lite-On Qualcomm Atheros QCA9377 Bluetooth type: USB driver: btusb 
  bus ID: 1-5:3 chip ID: 04ca:3015 class ID: e001 
Bluetooth:
  Device-1: Lite-On Qualcomm Atheros QCA9377 Bluetooth type: USB driver: btusb v: 0.8 
  bus ID: 1-5:3 chip ID: 04ca:3015 class ID: e001 
  Message: Required tool hciconfig not installed. Check --recommends 
Drives:
  Local Storage: total: 1.14 TiB used: 131.92 GiB (11.3%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10SPZX-21Z10T0 
  size: 931.51 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: 1A02 scheme: GPT 
  ID-2: /dev/sdb maj-min: 8:16 vendor: SK Hynix model: HFS256G39TND-N210A 
  size: 238.47 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: SSD serial: <filter> rev: 1P10 scheme: GPT 
Partition:
  ID-1: / raw size: 465.61 GiB size: 457.3 GiB (98.22%) used: 131.92 GiB (28.8%) 
  fs: ext4 dev: /dev/sda2 maj-min: 8:2 
  ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%) used: 696 KiB (0.2%) 
  fs: vfat dev: /dev/sda1 maj-min: 8:1 
Swap:
  Alert: No Swap data was found. 
Sensors:
  System Temperatures: cpu: 29.8 C mobo: 27.8 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 243 Uptime: 30m wakeups: 9 Memory: 11.57 GiB used: 2.55 GiB (22.0%) 
  Init: systemd v: 247 target: graphical.target Compilers: gcc: 10.2.0 Packages: 
  pacman: 1359 lib: 319 Shell: Bash v: 5.1.4 running in: konsole inxi: 3.3.01 
~ 
::

Solved

My mistake! For the sake of simplicity, I booted from another Arch based GRUB menu which Hefftorlinux does not recognize.
In the future, I will boot with the correct boot loader using the F12 key.

Glad you got it sorted :smiley:

1 Like

Thanks for the feedback @Brad

I boot from my “Universal GRUB” because it recognizes all of my operating systems and their DEs.
Hefftorlinux only recognizes itself. There is certainly a reason for that :wink:

Of course, I didn’t register in the forum to criticize the bootloader. But because I love this arco derivative for its light and elegant appearance thanks to kde plasma. The stable system, thanks to ext4 and the breathtaking speed with the Zen header.
Hefftorlinux ushers in a new era in the stuck Arch Linux.

Keep it up!

Thanks mate, we are working on pushing Zen as default kernel for the next Hefftor release :slight_smile:

Im looking into making btrfs as default option for the erase option on the partition tab. but that will be a maybe if testing all goes well :slight_smile:

Thanks heaps for your feedback I really appreciate you taking the time :smiley:

Thank you, you are a great team :+1:

Please let me add my two cents here based on my personal experience.

I don’t know the specific reason but the only way I can get Grub Customizer running is by opening up a shell window and do a ‘sudo grub-customizer’. Then it will work just fine. And yes, of course you can set it up in a way that it starts automatically a kernel of your choice. I am not aware of any kind of limitations when it comes to OS detection unless we are talking Windows 10 here which is a M$ issue that has nothing to do with Hefftor Linux.

Thank you for your reponse.

‘sudo command’ of course :grinning: In the ‘grub cuszomizer’ I can start Hefftorlinux with all installed kernels, whereby I prefer the Zen kernel. Windows is absolutely negligible. In addition to Hefftorlinux, I have installed another arco derivative, which is visually very similar to the Hefftorlinux, but which is not recognized in the ‘grub customizer’.
My temporary solution now is to use the other grubloader and let Hefftorlinux start there first. With this setting I don’t have to worry about a restart - and Hefftorlinux is ready.

To clear that up - Hefftorlinux cannot recognize my second arch-based distro because it uses the (experimental) Btrsf file system.
The presets in the Grub Customizer (Zen first) are to my liking.

Conclusion: I’ve been using Hefftorlinux every day for 4 months and there hasn’t been a single problem unless I do it myself. :grin:

Yes, and thank you very much for the Studio Edition. It’s very beautiful, very fast and absolutely stable. :+1:

Off-topic

Spring-like temperatures of around 25 °C prevail in southwest Germany. The freshly arrived Classic Tee Black fits perfectly!

Thanks for the many views of this thread :grin:

The “Grub Customizer” issue does not work is obsolete and can be closed as resolved because it was my own fault that it did not work. It has cleared up. Thanks for closing the topic.